Szukaj:
PL EN ES
Polecamy



Kalendarz treningów






Alfaholicy_SimRacingPL Server
Wróć   SimRacing wyścigi online > [SLS] Simracing League System > SLS support forum > SLS German support forum

PHP5: Leere Seiten (während und nach ausgetrickster Installation)

Zarejestruj się Projects Kalendarz Szukaj Dzisiejsze posty Zaznacz Wszystkie Fora jako Przeczytane

SLS German support forum German only.

Odpowiedz
LinkBack Narzędzia wątku Wygląd
stare 21-04-2008, 19:44   Post #1 (permalink)
Awatar Macro
 
Zarejestrowany: Apr 2008
Postów: 7
PHP5: Leere Seiten (während und nach ausgetrickster Installation)

Hallo

Ich versuche gerade SLS auf unserem Gameserver zum laufen zu bringen. Es handelt sich um XP SP2 und als PHP-Version ist PHP5 installiert.

Leider habe ich das Problem dass nach dem letzten Schritt der Installationsvorbereitung die Seite einfach leer bleibt (der HTML-Sourcecode endet einfach irgendwann). Ich habe Versucht über einen SQL-dump und die prefs.php eines Kollegen die Installation zu umgehen, leider bleibt auch die index.php einfach leer (Datenbankkonfiguration ist korrekt, die Tabellen wurden mit dem Dump korrekt importiert).

In einem alten Post habe ich gelesen dass die globals sowie long_arrays (oder so ähnlich) in der php.ini aktiviert werden müssen. Leider hat auch das nichts geholfen.

Als leztes habe ich versucht auf PHP4 zu wechseln mit welchen ich aber den Apache 2.2 nicht mehr starten kann (selbst mit einem Installer und mehrfachen prüfen der httpd.conf sowie php.ini).

Ich bin mit meinem Latein wirklcih am Ende (gut, kenn mich mit PHP nicht aus ) aber selbst der Kollege der sich auskennt weis keinen Rat mehr.

Ich hoffe hier kann mir jemand helfen

Danke
--Marc
Macro jest offline  
Odpowiedź z Cytatem
stare 24-04-2008, 08:23   Post #2 (permalink)
Awatar lupopa
 
Zarejestrowany: Aug 2006
Skąd: Germany
Postów: 121
Wyślij wiadomośc poprzez ICQ do lupopa Wyślij wiadomośc poprzez MSN do lupopa
Installiere Dir doch mal das XAMPP, habe bei mir mal @home das XAMPP eingerichtet PHP5 aktiviert und funktioniert mit SLS problemlos...
lupopa jest offline  
Just4Fun League, see on our fliegende-racer.de
rfactor Stats with Hotlaps, Drivers, new Driver, wrong Driver and many more, get it here: rfactor stats


Odpowiedź z Cytatem
stare 24-04-2008, 20:42   Post #3 (permalink)
Awatar Macro
 
Zarejestrowany: Apr 2008
Postów: 7
Hey danke für die Info.
Könntest du mir eventuell einfach mal deine Apache-Konfig und insbesondere die php.ini and willkeinspam@gmail.com schicken. Das wär einfacher, weil ich dann nicht unsere aktuelle Installation (für die Homepage) verändern müsste.

Die php.ini sollte aber eigentlich schon reichen (liegt irgendwo im PHP-Verzeichnis).

Das wäre super. Schon einmal Danke.
-- Marc
Macro jest offline  
Odpowiedź z Cytatem
stare 25-04-2008, 10:10   Post #4 (permalink)
Awatar lupopa
 
Zarejestrowany: Aug 2006
Skąd: Germany
Postów: 121
Wyślij wiadomośc poprzez ICQ do lupopa Wyślij wiadomośc poprzez MSN do lupopa
Das ist doch nur ne standard installation, habe nicht mal was im XAMPP geändert...
solltest Du eigentlich auch haben, oder?
lupopa jest offline  
Just4Fun League, see on our fliegende-racer.de
rfactor Stats with Hotlaps, Drivers, new Driver, wrong Driver and many more, get it here: rfactor stats


Odpowiedź z Cytatem
stare 25-04-2008, 19:56   Post #5 (permalink)
Awatar Macro
 
Zarejestrowany: Apr 2008
Postów: 7
Die XAMP Installation erledigen noch ein paar Dinge mehr, z.B. die Installation der passenden Extensions inkl. Konfiguration.

Ich hab PHP auch einfach Standardmäßig installiert, die Dokumentation gewälzt und einige Forenbeiträge beachtet. "Eigentlich" müsste alles funktionieren...tut es aber irgendwie nicht
Macro jest offline  
Odpowiedź z Cytatem
stare 25-04-2008, 21:34   Post #6 (permalink)
Awatar Macro
 
Zarejestrowany: Apr 2008
Postów: 7
Jetzt funktioniert es endlich.

Und auf die Idee muss man erst einmal kommen...der Standardinstaller von PHP ist fehlerhaft. Man muss den Mist manuell installieren und dann die gewünschten Extensions in der php.ini auskommentieren.

Also dass ein Installer so einen Käse fabriziert hab ich auch noch nicht erlebt, naja egal jetzt tuts ja.

Danke
Macro jest offline  
Odpowiedź z Cytatem
Odpowiedz

Bookmarks

Narzędzia wątku
Wygląd

Zasady Postowania
Nie możesz zakładać nowych tematów
Nie możesz pisać wiadomości
Nie możesz dodawać załączników
Nie możesz edytować swoich postów

BB Code jest Włączony
EmotikonyWłączony
[IMG] kod jest Włączony
HTML kod jest Wyłączony
Trackbacks are Włączony
Pingbacks are Włączony
Refbacks are Włączony



Czasy w strefie GMT +2. Teraz jest 19:33.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
SimRacingPL

no new posts

Logowanie
Login:
Hasło:
 Zarejestruj się!

321 osób online
320 Gości
1 Zalogowanych
Facebook
Administratorzy
Administracja portalu
Owner
McLaren
Senior Admin
lelu0
Summer RC Cup 2018
lelu0
Admins
SirDuncan - Historic (GiW) Admin
Moderators
Dmnick - Super Moderator
sobol - Moderator